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1. Objective 
 
This Tutorial contains a step-by-step procedure for simulating a common source 
amplifier circuit in the Mentor Graphics Design Architect tool. It covers DC Analysis, 
Transient Analysis, DC Operating Point Analysis and AC Analysis simulation of the 
amplifier. 
 
This tutorial assumes that the schematic of the amplifier has already been created. For 
help with creating schematic and symbol, please refer to the Analog IC Schematic Entry 
tutorial. 
 
 



 

 

2. Basic Test Circuit Creation 
 

• Open icstudio from the command prompt as in the Schematic Entry tutorial 
• Create a new view in the created library (analogtut) and name it test_amplifier with 

view type as Schematic. We will use this sheet to create basic test circuit required for 
the simulations. 

 

 

 



 

1.  Adding an Instance to the test circuit  
A new schematic entry sheet opens in DA-IC. In the test_amp schematic: 
 
• Add the symbol for the amplifier that you generated in the schematic entry tutorial.  

o Click Add > Instance from schematic_edit palette on RHS.  
o In the Choose Symbol popup window, click Browse, navigate and select 

CommonSource and click OK. Place this symbol of the inverter in the sheet 
as shown in the figure below. 

• Add PORTIN, PORTOUT, VDD and Ground from the Generic Lib 
• Name the ports as VIN & VOUT, and wire them to the VIN and VOUT pins of the 

amplifier symbol as shown in the figure. 
• Add a DC source by selecting IC_Library > Sources Library > DC. 
• Highlight the DC source, right click mouse, Properties > Edit to modify the voltage 

value of the source from 1V to 3.3V. 
• Connect the positive node of the DC source to VDD symbol and negative terminal to 

the Ground symbol.  
• Add second DC source for the input, and connect to VIN. Edit the properties to set 

INST = Vs 
• Click Check & Save. If there are any errors, correct them before moving on. 

 
 

 



 

 2.  Setting up the simulation parameters 
Click on simulation from the schematic_edit palette on the RHS to enter the simulation 
mode. A popup window appears with a Warning message, indicating that the schematic 
will be closed. Click OK to accept default options. 
 
In the simulation mode (schematic_sim palette): 
• On the simulation palette, click the button Lib/Temp/Inc > Library. 
• Type /opt/mentor-2004.3/sol/adk2_5/technology/ic/models/tsmc035.mod in 

Library path box and click OK.  
This includes the TSMC0.35 micron BSIM model for the simulations. 
 
The screen should look like the figure below: 
 

 



 

 

3.  Setting up the Simulator / Viewer 
 
In the simulation mode (schematic_sim palette),  
• Click Session > Simulator / Viewer. 
• Select Eldo under Simulator and EZwave under Viewer and click OK. 

 

 
 
 
Click on Check & Save.  You are now ready to run an analysis on the amplifier. 



 

2. DC Analysis 
 
For a DC analysis, we will sweep the input voltage, Vs, from 0V to 3.3V and view its 
effect on the output. 
 

1.  Editing and simulating the test circuit  
 
• Open the test_amp schematic sheet and make sure that you are in schematic_edit 

mode. 
• From the steps above, the input to the amplifier should already be a DC voltage 

source between VIN and Ground. If not, change the input source to a DC voltage 
source. The source should be named Vs. (Note that the value of the DC voltage 
source is 1V, by default. For the DC sweep we will be doing, this value does not 
matter and so you can leave it as it is.)  

• Click Check & save the sheet and then enter the simulation mode by clicking on 
simulation from the schematic_edit palette on the RHS. Click OK to accept the 
default options in the Warning popup window that appears. 
 



 

2.  Setting up the simulation parameters 
 
On the schematic_sim palette: 
• Click on Lib/Temp/Inc > Library to make sure that  

/opt/mentor-2004.3/sol/adk2_5/technology/ic/models/tsmc035.mod appears 
in library path box and click OK. 

• Click Setup > Analyses.  
• In the Setup Simulation Analysis window that appears, select DC and click on 

Setup associated with DC. In the Setup box that appears, select Source and 
select VS for Voltage source, put 0 in the start field, 3.3 in the stop field and 
10m in the step field and then click OK. 

 

 



 

2.  Setting up the simulation parameters 
• Click Probes/Plots > Save All…from the Palette. This opens a dialog box for 

choosing which signals should be saved for later analysis. 
• Make sure the Voltages and Currents boxes are checked, and click OK.  

 

 
 
 

3.  Executing the simulation setup 
 

On the schematic_sim palette: 
• Click Execute > Netlist. This opens up a new window that starts netlister. Check 

the netlist created for any errors. If there are any errors, correct them before 
proceeding further. Else close the window by pressing Enter key. 

• Click Execute > Run Eldo. This starts Eldo in a new shell window and it may 
take few seconds before the simulation is complete. You may scroll down the 
window to see the DC simulation results. Press Enter key to close the Shell 
Window. 

 



 

4.  Viewing the results using EZWave viewer 
To view the results of your DC analysis in EZWave, do the following: 
On the schematic_sim palette: 
Click Results > View Waves. A new window will open as shown below. 
 

 
 

Under test_amp_eldonet > DC > X_COMMONSOURCE, Highlight both V(VIN) and 
V(VOUT), then right click, and select Plot (Overlaid) 
 

  



 

 
This DC analysis shows you where to set the DC bias point of the transistor. From the 
input/output plot, we see that the high gain region corresponds to a DC input voltage of 
about 1.0V to 1.8V. In the subsequent analyses, you will set a DC bias voltage of 1.5V at 
the gate of the transistor, ensuring that the device is operating in the the correct region.  

 

5.  Printing the plots 
 
To Print your waveform: 

 Click File > Print. 
 Type `laser` for the printer name & Click OK. 

 

 
 
 
 



 

4. Transient Analysis 
In this section, you will provide a sinusoid at the input and view the input & output 
waveforms. 

1.  Editing and simulating the test circuit  
• Open the test_amp sheet that you have created with the symbol of your amplifier 

and make sure that you are in schematic_edit mode. 
• Remove any existing input sources and add a SIN voltage source between the 

VIN pin and Ground as shown in the following figure. 
• Name this sourse as Vs and change the attributes as: 

ampl  0.1V (AC amplitude of the input) 
freq  100kHz  
offset  1.5V (DC bias point, as found in the DC analysis) 

 

 
 

• Check & save the sheet and then enter the simulation mode by clicking on 
simulation from the schematic_edit palette on RHS. Click OK to accept default 
options in the Warning popup window appeared. 

 
 



 

2.  Setting up the simulation parameters 
 
On the schematic_sim palette: 
• Click on Lib/Temp/Inc > Library to make sure that  

/opt/mentor-2004.3/sol/adk2_5/technology/ic/models/tsmc035.mod appears in 
library path box and click OK. 

• Click Setup -> Analyses. In the Setup Simulation Analysis window that 
appears, select Transient and click on Setup associated with it.  

• In the Setup box that appears type 100u in the Stop Time field and 100n in Max 
Time Step field. Then click OK. 

 

 
  
 
 



 

3.  Setting up the signals to be probed 
• Click Probes/Plots > Save All…from the Palette. This opens a dialog box for 

choosing which signals should be saved for later analysis. 
• Make sure the Voltages and Currents boxes are checked, and click OK.  

4.  Executing the simulation setup 
• Click Execute > Netlist  
• Click Execute > Run ELDO 

5.  Viewing the results using EZWave viewer 
To view the results of your transient analysis in EZWave, do the following: 
On the schematic_sim palette: 
• Click Results > View Waves. A new window will open as shown below. 
• Under test_amp_eldonet > TRAN > X_COMMONSOURCE : 

o Highlight both V(VIN) and V(VOUT), then right click, and select : 
Plot (Overlaid) 

 
 

 



 

6.  Measuring Gain with the EZWave Measurement Tool 
To measure the gain of the circuit from the transient analysis in EZWave, do the 
following: 
 
• Select VOUT by clicking the yellow trace. 
• From the menu, select Tools > Measurement Tool 
• Click the Add Selected Waveform button 
• Select V(VOUT) as the Source Waveform 
• Select General > Peak-to-Peak as the Measurement 
• Click Apply 
• Repeat for the VIN waveform 
 

 
 

 



 

 
 
 
Many other measurements can be made with the EZWave Measurement Tool. 



 

5. DC Operating Point Analysis 
 

In this section, you will find the DC operating point of several nodes in the circuit. The 
input of the amplifier should be configured as in the above transient analysis. 
 

1.  Editing and simulating the test circuit  
• Open the test_amp sheet that you have created with the symbol of your amplifier 

and make sure that you are in schematic_edit mode. 
• Remove any existing input sources, and add a SIN voltage source between the 

VIN pin and Ground as shown in the following figure. 
• Name this sourse as Vs and change the attributes as: 

ampl  0.1V (AC amplitude of the input) 
freq  100kHz  
offset  1.5V (DC bias point, as found in the DC analysis) 

2.  Setting up the simulation parameters 
On the schematic_sim palette: 
• Click Setup > Analyses. Select DCOP in the dialog box that appears, and then 

click OK. 

3.  Executing the simulation setup 
• Click Execute > Netlist  
• Click Execute > Run ELDO 

4.  Viewing the results using Monitors 
The next step is to view the results of your simulation run. 
To see all the DC voltages and currents in your schematic,  
• Click Results > DCOP > Add monitor > All Nets – Voltages  
• Again click DCOP > Add monitor > All Pins - Current 

 



 

 
 
Current and Voltage values at various nodes will be displayed as shown in the above 
figure. 
 
Alternately, you can select voltages or current option, if you want to see only voltages or 
currents. 



 

 

5.  Static Power consumption of the circuit 
The static (DC) power consumption of the circuit for the given operating point is 
calculated during the DCOP simulation.  
 

• Click on Results > ASCII Files, right click mouse button > View Log. 
•  Scroll down in the log window to find the information about the power 

consumption as shown in the figure below: 
 

 
 



 

6. AC Analysis 
 
In this section, you will run AC analysis and trace and measure your results. In AC 
Analysis, the input signal is swept over a range of frequencies.  

1.  Editing and simulating the test circuit 
• Open the test_amp sheet that you have created with the symbol of your amplifier 

and make sure that you are in schematic_edit mode. 
• Remove any existing input sources, and add an AC voltage source between the 

VIN pin and Ground 
• Name this sourse as Vs and change the attributes as: 

mag  1V (AC amplitude of the input) 
offset  1.5V (DC bias point, as found in the DC analysis) 

 
Note: While 1V can not be considered a small signal input for this circuit, it is acceptable in the AC simulation 
since SPICE does not use a large-signal model for the AC simulation. SPICE first runs a DC operating point 
analysis to construct the small signal model, then uses the specified AC voltage in the linear model. By setting the 
input to 1V, the output voltage equals the gain directly. (AV = Vout/Vin) 
 
• Add a 10pF capacitor at the output of the amplifier as shown below 
• Click Check & save the sheet and then enter the simulation mode by clicking on 

simulation from the schematic_edit palette on RHS. Click OK to accept default 
options in the Warning popup window appeared. 

 



 

2.  Setting up the simulation parameters 
On the schematic_sim palette: 
• Click Setup > Analysis. Check AC and click on the Setup box associated with it. 

Select the Decade button for Sweep type. For this circuit you will perform an AC 
sweep of input frequency from 1k to 10MEG. Enter 100 in the Points per 
Decade box. Enter these values in the Start Freq and Stop Freq respectively. 
Click OK 

 
 
 

 

3.  Setting up the signals to be probed 
• Click Probes/Plots > Save All…from the Palette. This opens a dialog box for 

choosing which signals should be saved for later analysis. 
• Make sure the Voltages and Currents boxes are checked, and click OK.  

 

4.  Executing the simulation setup 
• Click Execute > Netlist  
• Click Execute > Run ELDO 



 

 

5.  Viewing the results using EZWave viewer 
To view the results of your transient analysis in EZWave, do the following: 
On the schematic_sim palette: 
• Click Results > View Waves. A new window will open as shown below. 
• Under test_amp_eldonet > TRAN > X_COMMONSOURCE : 
• Highlight V(VOUT), then right click, and select : Plot 

 
 

 
 



 

7. Parameter Sweeps 
 

It is often helpful to perform an analysis on one parameter while simultaneously 
sweeping another parameter. This concept will be demonstrated by generating the ID vs 
VDS curves for a MOSFET. 
 

1.  Editing and simulating the test circuit  
• Create a new schematic view and draw the circuit shown below. (Name the gate 

voltage source VGS and the drain voltage source VDS. Both sources are DC) 
• For VGS, set Mag = vgate 
• Click Check & save the sheet and then enter the simulation mode by clicking on 

simulation from the schematic_edit palette on RHS. Click OK to accept default 
options in the Warning popup window appeared. 

 
 

 



 

 

2.  Setting up the simulation parameters 
On the schematic_sim palette: 
• Click on Lib/Temp/Inc > Library to make sure that  

/opt/mentor-2004.3/sol/adk2_5/technology/ic/models/tsmc035.mod appears in 
library path box and click OK. 

• Click Setup > Analyses.  
• In the Setup Simulation Analysis window that appears, select DC and click on 

Setup associated with DC. In the Setup box that appears, select Source and 
select VDS for Voltage source, put 0 in the start field, 3.3 in the stop field and 
10m in the step field and then click OK. 

 

 
 

• Click Probes/Plots > Save All…from the Palette. This opens a dialog box for 
choosing which signals should be saved for later analysis. 

• Make sure the Voltages and Currents boxes are checked, and click OK.  
 



 

3.  Defining Parameters 
• On the simulation palette, click Parameters, and enter into the first empty box: 
 

Vgate  0 
 

 
 
 



 

4.  Setting up Multiple Runs 
• Click Multiple Runs > Sweep  to bring up the Sweep List Editor 
• Under Multi-Run Mode, select Sweep 
• Click Add Sweep 
• Select Param, and choose vgate as the Parameter name 
• Setup the sweep for Lin/Num Pts, 0 to 3.3, with about 15 steps. Click OK 
 

 

 
 
 
 

5.  Executing the simulation setup 
On the schematic_sim palette: 
 
• Click Execute > Netlist.  
• Click Execute > Run Eldo 

 
 



 

6.  Viewing the results using EZWave viewer 
To view the results of your DC analysis in EZWave, do the following: 
On the schematic_sim palette: 
 
• Click Results > View Waves. A new window will open as shown below. 

 
Under curvetracer_eldonet > DC > M1 : 
 
• Highlight I(D) then right click, and select Plot 

 

  
 
 


