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1. Objective

This tutorial shows a step-by-step procedure for creating a custom (manual) layout of the
inverter schematic that you created in Schematic entry tutorial. The final schematic is
shown in the figure below.

It also helps you verify your layout by using the IC Station physical verification tools
Calibre to perform simple DRC (Design Rule Check), and LVS (Layout vs Schematic)
check.

Xt Design Architect-IC ¥2006.1_2.3 (p081906) - Project ¥lsiTutorial =10 1‘
Fle Edit Selct Smubtion Commib Mew Tools Setup Report Mindow Help

i e
VB e R QA

(Session Viewpoint: $Dema_lnver

aroupAogic. views/inverter/eldonet)

| Demo_Inverter : Inverter : DesignConfig schematic sim ||

égf | = End Sim

% ADK Sim Palet
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ﬁ Session

= Lib/Temp/ine
Analyses...
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5 arameters...

. Forces
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Options
Multiple Runs
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Measurement:
Model Selectc

Execute
Netlist

T Results
ASCIl Files

View Waves
Crass Probe
View Measure
DCOP

Utilities
Annotations
Mixed Signal

_ Quick Referent
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Note : Reading version 1 of sheet $Demo_Inverf agroupfagic views/inver 1 =
Note : Userware file $MIGC_HO ichuser c_sim_spe.ample loated. I
Note : Name mapping file wiitten.
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2. Setup & Preparation

The set of directives listed below is applicable to users of the Engineering Design Center
at Santa Clara University. If you are working in a different environment please check
with your system administrator.

The steps below are necessary only for the first time to setup the Mentor Graphics
environment by changing the settings in your .profile file.
Add the following lines in your .profile:

setup mentor-2008.1
alias swd="export MGC_WD=\"pwd\’”

Remember to execute

$ . .profile
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3. Launching IC Studio

On the command line
» To Create a directory to contain your projects type:
“mkdir Tutorial”
» To change the current directory to Tutorial type:
“cd Tutorial”.
» Toopen ICSTUDIO type:
“icstudio”.

This launches the 1CStudio window shown below.

= ) ICstudio — Project ¥

Eile Edit Tools Help
=& 2 B e X B

Selected:

Library [
& 1Dema_lnverter :

- _aMGC_DESIGN_KIT

e _AMGC_IC_COMMLIB

- gMGC_IC_COMMLIB_GS
- _@MGC_IC_COMMLIB_RF
+I-AMGC_IC_DEVICE_LIB
- 4MGEC_IC_GENERIC_LIE
+-_4MGC_IC_SOURCES_LIB
+-AMGC_IC_VERILOG_LIB
- gMEC_MACROLIB

Note: Reading user settings

Note: Opening project "/fusers/student/asharan/workdir/VlsiTutorial proj"
Note: Reading preferences from current MGC_HOME

Note: Reading preferences for this project

Note: IGstudio startup complete

Log

A
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4. Opening the project

To create a project the follow the three steps given below:

1. Opening icstudio and opening the project
On the ICStudio Window

NX - asharan@noval4. dc.engr.scu.edu:1003 - MentorGraphics

Click File -> Open -> Project to create a new project.
Enter the Project name (e.g visi_tutorial) and the Project Location
Click Open in the Open Project pop-up window

ICztudio - Project YlsiTutorial

;
|1

File Edit Tools Help

IEEEES R EELd

Selected; Deno_Inverter / Inverter / Lagout

;"l:]DEmD_II"IUET‘LET
+1-_gMEE_DESIGN_KIT
+1-_MGC_IC_COMMLIB

+- | gMGC_IC_COMMLIE_QS
+1-dMGC_IC_COMMLIE_RF
+1- QMGC_IC_DEVICE_LIB
41 4MEC_IC_GENERIC_LIE
+1-_MBC_IC_SOURCES_LIB
41 MG _IC_YERILOG_LIB
+1-[_gMGC_MACROLIB

Library

1 Inverter
i Test_inverter

Open Project I

Look in: I{deent/asharan/workdlrﬂ %' = = el

-

@

ha Miveds ignalTutorial,proj
|y l= i Tutorial goro i

File name: IVLSiTutarlal‘proj

File type: I,ggﬁpru,jects (=, proj} j Cancel

B ochehat 10
[5] Sunbol

7 |
£ PARNING ¢ Fort loading failed, Please see the following notes for more information,
A4 NOTE: Hhost, = 'novald . -
A4 MOTE: Hoeruer = 'novald',
A/ MOTE: font name = 'ic,icons'. -
4] N
&llog I 2% IC Station I

v

2. Opening Layout Cell

Right click on the name of the Schematic you entered (eg.; Inverter) and click

New View.

Select View Type as Layout.

Click Finish.
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NX - asharan@noval4. dc.engr.scu.edu:1003 - MentorGraphics

.
|=1 =]

= ICstudio - Project YlsiTutorial
File Edit Jools Help
R 2 ElEL

Selected: Teno_Inverter / Inverter

P Dema_Inverter T Inverter
-_@MGC_DESIGM_KIT T Test_inverter
-_aMGC_IC_COMMLIE

-_aMGC_IC_COMMLIB_RS

- @MGC_IC_COMMLIB_RF

_4MGC_IC_DEVICE LIB l_'
- _AMGC_IC_GEMNERIC_LIB
- gMGC_IC_SOURCES_LIE EEEEREEEN
_4MGC_IC_YERILOG_LIE
- AMGC_MACROLIB Library Manst  [Demo_Tnverter

R O O W B = B

Cell Hamet IInVBT‘tET‘

View Type: & Layout. v

Dptions
’7Uiew Mame: ILaHUut

@Jalp | < Back | Mext > | Finish I Cancel |

I [ |
£ HARMIMG ¢ Font. loading failed. Please ses the following notes for more information.
A4 HOTE: Hhost = 'novald ', i
A4 MOTE: Haerver = 'novald .
A4 MOTE S font. nane = 'ic,icons'. -
4« 3
Loz I % IC Station I

A

The following window will open wherein you can draw your schematic layout.
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=lBlx|

m

24 Edt  Selkect Mew Conneotity ool Setyp Beport Window Hep ADK

|g\qq|a Select: [0 X i DX DY

width kL Layer ~| Viastyle: S o |

e

f

=

COMMENT [l svE| Ll
|| tsmonas

=

1C 0: Demo_inverter / Inverter / Layout > Demo_Inverter / Inverter 7 Layout (i)(GE-E)

i

a5 [av [aF
COMM... 1
METAL... 2
METAL... 3
METAL...4
ANALOGE
BE_PAD 7
MARKER 8
METAL... 10
METAL... 11
P_HIGH..21
N_HIGH..22
MEMS_..23
MEMS_..24
CONTA...25
PADS 26

METALA 31 [lavi
Vied 32 ave
METALS 53 W ovi
HLRES. 34  Elsvf
PWELL 41 = ovf
N_WELL 42 [llsvt
ACTIVE 43 8 vi
P_PLUS.44 W svE
NPLU. 45 W ovi
poLy 45 [llsve
CONTA.47 8 svf

Y
B3
]
(]
(g
r
&
A3
0O
&
@,
@,

wPath v Array
wTert v Overflow
~l| vShape  Pin
< > | instance v Device

Mouse:  L: [Full Selection M: [Fstar_stroke() R: [View Area

Note: Before you make any changes to your work, make sure your work is in the 'Edit’
mode.
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5 Drawing the Layout

For this Click File> Enable editing > Current Context

iTutorial

Edft Gelect Wew Connectivity Iook Setyo Feport Window Hep ADK

=lBlx|

New. R & | e select [0 X: [-22.000 V: [33.000 D3: [~7.000 Dv: [32000

oen PR L ter [ o Vaswe o] 4o ¢l

1C 0: Demo_inverter / Inverter / Layout > Demo_Inverter / Inverter 7 Layout (i)(GE-E)

e ity »
B0 (0]t oot
5

Feyert to Saved
SRR Heraety
Respnc By Name.
Upgate.
Cheefgoint
Load Fules.
Unloadt Cells

Print
Import.
Export

o

METAL]
tsmc0as

| B

COMM... 1
METAL... 2
METAL... 3
METAL...4
ANALOGE
BE_PAD 7
MARKER 8
METAL... 10
METAL... 11
P_HIGH..21
N_HIGH..22
MEMS_..23
MEMS_..24
CONTA...25
PADS 26

DIFFUS.
METAL
METAL
METAL
METAL

METAL.. 164 Bsvi

[#Path [ Array
[P Text [+ Overlow
[#shaps  ¥Pin
I T 13] | ¥instance v Device
Mouse:  L: [Full Selection — M: [fsta _sfroke R [View Area

NOTE: The layout will not be automatically drawn for you. You need to
draw it on your own through scratch. The above figure is just for

illustration. How to enable editing mode.
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1. Actual Inverter Layout

Now that we are familiar with basic editing commands, lets start with the layout of the
inverter.

Note:In the working space, one unit is equal to one Lambda (A4). (refer to the cursor
coordination on the window frame). If you follow the Lambda rules for TSMCO0.35u
technology, the smallest feature size will be 24 = 0.4u (for poly width and contact size).
Therefore we have 14 = 0.2micron

e To Create the NMOS with 0.4 micron length and 1.2 micron width:
o Click ACTIVE(43) on RHS of the window.
o Click Draw Rectangle on the LHS of the window and draw a 6AX6\ square
of layer 43.
o Next create CONTACT_TO_ACTIVE (48) 2A x2A Square.
o Next create 6A X6A METAL1 Square for Contact.
. The result should look like in the following figure.

i IC Station, v2006.1_2.2 (p071406) - Project VisiTutorial _181x]

Fle fdd  Eoit  Select Mew

Connectivity  Tools  Setun  Feport  Window  Help  ADK
= | B & & | oot [0 X: [36.000 . [~5.000 DX: 52000 DY: [Ta000
+1 |37 wistn L Laver -| Viastyle: =V

CONTACT_T. s 1l
4| temcO3S

1C 0: Damo_Inverter / Invertar / Layout > Demo_Inverter / Inverter 7 Layout (i)(GE-E)

a5 [av [aF =
=S COMM.. 1 EMlsvt 4]
3¢ METAL. 2 Ellsvt
METAL. 3 Ilsvi
] METAL.4  IMllsvE
aNpLOGE  EMlsvE
o Be_PAD 7 MMlavi
= MARKERS  Ellovi
B METAL.. 10 [#fsvi
O, METAL. 11 Ssvf
F_HIGH..21  EllsvE
I N_HIGH..22  EllsvE
I MEMS_.23  EllsvE
MEMS_ 24 Ellsvf
A3 CONTA..25  MMlavi
PeDs 26 EMsvi
0 siLicD.. 23 Mlsve
& Va3 G0 W svE
METALA 31 [svE
o, viad 32 svf
@, METALS 33 @ ovi
HI_RES. 34  Mllsvf
BiE PWELL 41 = ovi
o N_WELL 42 [llsve
B ACTIVE 43 8 svf
P_PLUS.44 MW svE
N_FLU.. 45 W ovE
CONTA A ez

CONTA..48

vt
METALT 49 [llsvi
Via 50 W ovE
METALZ 51  [WMsve
OVERG.52 WMlsvi
CONTA..55 vt
ELECT.. 56 WWsvf
BURIED..57 MMl=vE
PEASE 50 MMlevi
ceP_..53  Ellsvi
Thick_A..60  [88svf
viez 61 svf
METALS 62 [Mlsvt
DIFFUS..111 EllsvE
METAL.. 149 llsvE
METAL.. 151 IllsvE
METAL... 162 llsvi
METAL... 163 Mlave
METAL... 164 Bl ovE

Mouse:  L: [Full Selection M: [fstart_stroke() R: [View Area d~design, r-routing, a-named, u-user, v-change visibility, - change fil, s-change selection, cntrl-x cut, entrl-v paste

e Select both the shapes and Click Edit> Copy> Selected
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e Next Click Edit> Paste
e Place all these shapes beside the original ones with 4 spacing. They are source and
drain contacts.

o Create 61 x 161 ACTIVE (active area) to cover exactly source and drain metal
contact.

Next

e To Make the PMOS:
o Click ACTIVE(43) on RHS of the window.
o Click Draw Rectangle on the LHS of the window and draw a 6A X6\ square
of layer 43.
o Next create CONTACT_TO_ACTIVE (48) 2A x2A Square.
o Next create 18\ x6A METALL1 Square for Contact.
e Note: Distance between the NMOS and the PMOS should be at least 131

i 1C Station, ¥2006.1_2.2 (071406} - Project YlsiTutorial 181

He Add Edt Sekct Mew Connestity ool Setwp Beport Window Hep ADK

EEL TR RS ¥ [3.000 v: [-12:000 DX: [41.000 DV: 151000
] B width kL Layer | Viastyle S o |
1C 0: Demo_nverter J Inverter / Layout » Demo_Inverter { Inverter { Layout (i) (GE-E) CONTACT_T... = sl
. . . || tame0as
2 [av [aF =
' COMM..1  EMl=vi|~
» METAL..2  Ellsvi
METAL. 3  [sve
2 METAL.4  [Wlsv
ANALOGE  EMlsvE
Q BB PAD 7 MMlsvf
] MARKER S EllsvE
By METAL. 10 [#=vE
() METAL. 11 SEsof
F_HIGH..21  Ellevi
F N_HGH. 22 Ellsvi
7 MEMS_.23  Ilsvi
MEMS_.24  EMlsvE
A3 CONTe..25  EMlsvE
PaDS 26 MMlsvE
o SILICID.. 29 MllsvE
& Va3 a0 svE
METALA 31 [lavi
o Vied 32 ave
@, METALS 33 W svi
HRES.34  MMlsvi
18 PWELL 41 = ovf
= N_WELL 42 [llsvt
B ACTIVE 43 8 vi
P_PLUS.44 W svE
NPLU. 45 W ovi
poLy 45 [llsve
CONTA.47 8 svf
CONTA...48 svf
METALT 43 [llsvt
via 50 W svE
METAL2 51 Nsvi
OVERG..52 KMlsvf
CONTA...55 v
ELECT.. 56 Wsvi
BURIED..57 MMsvi
PEASE 50 MMsvi
Ccap_w.59  Ellsvi
Thick_A.60 8=t
viaz 61 vt
METALS3 62 IMllsvi
DIFFUS.. 111 Ellavi
mETAL . 143 Illsve
wETAL . 151 Illsve
METAL . 162 [Illsvf
METAL... 163 llsvE
METAL... 164 Bl svE
Path v Array
Tert v Overflaw
hap: “Fin
nstance [ Devi

Mouse:  L: [Full Selection M: [Gstar_strokeQ) R: [View Area F7-gravity, &/D-dragruler, v/v-align, g-drc, UF-1ip, UR-rofate

e Select all the shapes and Click Edit> Copy> Selected
e Next Click Edit> Paste
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e Place all these shapes beside the original ones with 4 spacing. They are source and
drain contacts.

o Create 18\ x 161 ACTIVE (active area) to cover exactly source and drain metal
contact.

i 1C Station, v2006.1_2.2 (p071406) - Project VisiTutorial 181X
Ble aid Edt Select Mew Con oo Se fieport  Window  Hep DK
Bl WA Q| e o X: [-5.000 v: 23000 DX: [15.000 DY: [4.000
=] 31 width L Layer -] Viastyle: ]
= ACTIVE 8 5 |
|| teme03s
a5 [av [aF =
=S COMM.. 1 EMlsvt 4]
3¢ METAL. 2 Ellsvt
METAL. 3 Ilsvi
] METAL.4  IMllsvE
aNpLOGE  EMlsvE
o Be_PAD 7 MMlavi
= MARKERS  Ellovi
B METAL.. 10 [#fsvi
O, METAL. 11 Ssvf
F_HIGH..21  EllsvE
I N_HIGH..22  EllsvE
= MEMS_.23  EllsvE
& MEMS_..24  EllsvE
A3 CONTA..25  MMlavi
PeDs 26 EMsvi
0 siLicD.. 23 Mlsve
& Va3 G0 W svE
METALA 31 [svE
o, viad 32 svf
@, METALS 33 @ ovi
HI_RES. 34  Mllsvf
BiE PWELL 41 = ovi
o N_WELL 42 [Slsve
B ACTIVE 43 [#lllsvf
P_PLUS.44 W svE
N_PLU.. 45 W ovE
poLy 45 [lsvi
CONTA.47 8 svi
CONTA..48 vt
METALY 49 [llsvi
Via 50 W ovE
METALZ 51  [WMsve
OVERG.52 WMlsvi
CONTA..55 vt
ELECT.. 56 WWsvf
BURIED..57 MMl=vE
PeasE 53 MMlsvE
cap W59 Ellevi
Thick_A..60  [8Hsve
viez 61 avf
METALS 62 [llsvi
DIFFUS.. 111 EllsvE
METAL... 149 Illsvi
METAL.. 1517 llsvE
METAL.. 162 Illsvi
METAL... 165 llavi
METAL... 164 IllovE

Path v anay
v Text v Overflow
 Shaps v Pin
“instance v Devi

Mouse:  L: [Full Sefection M: [fstart_stroke() R: [View Area F7-gravity, a/D-dragruler, u/V-align, g-dre, JF-fip, UR-rotate

e Next create a 41A X 2) poly between the drain and source contacts for NMOS and
PMOS.

e Add 22X x 201 P_PLUS_SELECT for PMOS and 10A x 201 N_PLUS_SELECT for
NMOS.

e The spacing between N_PLUS SELECT and P_PLUS_SELECT should be kept at
least 9 for correct NWELL and PWELL spacing as shown below.
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i 1 Station, ¥2006.1_2.2 (p071406) - Project VlsiTutorial M|
Fe fdd it Sebot Mew Connestvi

EEL TR RS ¥: [-27.000 v: [-26.000 DX: [-251000 DV: [-4.000
] B width kL Layer ~| Viastyle: S o |

Took  Setp Feport Wndow Hep ADK

N_PLUS_SEL...M svE| Ll
|| tsmonas

1C 0: Demo_inverter / Inverter / Layout > Demo_Inverter / Inverter 7 Layout (i)(GE-E)

2 [av [aF =
3 COMM..1  EMl=vi|~
METAL..2  Ellevi
B METAL. 3  [sve
9 METAL 4 [llsve
ANALOGE  EMlsvf
. BB PAD 7 MMlsvf
G MARKERS  EMlsvf
N | b METAL. 10 [#=vE
= METAL. 11 SRsvi
P_HIGH..21  Ellsvi
5 N_HGH. 22 Ellsvi
= MEMS_.23  Ellsvi
,,,,,, MEMS_.24  Ellsvf
AT, CONTA.25  MMlsvf
PaDS 26 EMsvE
L SILICID.. 29 MlsvE
& Va3 a0 svE
METALA 31 [lavi
LS e vied 32 v
@, | = METALS 33 WMsvf
HLRES. 34  Elsvf
18 PWELL 41 = ovf
= N_WELL 42 [llsvt
L ACTIVE 43 8 vi
»»»»»» L P_PLUS.44 W svE
N_PLU.. 45 (W ovi
PoLy 45 [llsve
CONTA.47 8 svf
CONTA..48 svf
METALT 43 [llsvt
via 50 W svE
METAL2 51 Nsvi
OVERG..52 KMlsvf
CONTA...55 v
ELECT.. 56 Wsvi
BURIED..57 MMsvi
PBASE 50 Mlsvf
CAP_W.53 Mlsvf
Thick_A.60 8=t
viaz 61 vt
METALS3 62 IMllsvi
DIFFUS.. 111 Ilsvi
mETAL . 143 Illsve
wETAL . 151 Illsve
METAL . 162 [Illsvf
METAL... 163 llsvE
METAL... 164 Bl svE

wPath v Array
wTert v Overflow
“ihape  WPin
“instance v Devis

Mouse:  L: [Full Selection M: [Gstar_strokeQ) R: [View Area F7-gravity, &/D-dragruler, v/v-align, g-drc, UF-1ip, UR-rofate

Note: It is always better to add as many CONTACTS as possible to reduce the
contact resistance. So add 3 contacts in the Source area of PMOS (with 3\
distance in between the contacts) and 4 contacts in the drain area of PMOS (with
2). distance in between the contacts) as shown in the adjacent figure.

Note: As per the design rules of TSMCO0.35, minimum separation between two
contacts should be 3.

e Add 30A x 281 NWELL for PMOS and 18 x 28\ PWELL for NMOS. The spacing
between NWELL and PWELL should be at least 1.
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i 1 Station, ¥2006.1_2.2 (p071406) - Project VlsiTutorial M|
Fe fdd it Sebot Mew Connestvi

Took  Setp Feport Wndow Hep ADK

EEL TR RS ¥ [18.000 v: [1.000 DX: [16.000 DV: [27.000
] B width kL Layer | Viastyle S o |
1C 0: Demo_nverter J Inverter / Layout » Demo_Inverter { Inverter { Layout (i) (GE-E) PWELL  mov[ll
|| tsme0as
2 [av [aF B
e COMM.. 1 Ellsv [~
» METAL..2  Ellsvi
METAL. 3  [sve
2 METAL.4  [Wlsv
ANALOGE  EMlsvE
<@ BE_PAD 7 EMlevE
bl - MARKER S EllsvE
= METAL. 10 [#=vE
i METAL. 11 SRsvi
F_HIGH..21  Ellevi
F N_HGH. 22 Ellsvi
7 MEMS_.23  Ilsvi
MEMS_.24  EMlsvE
A; NN ., CONTe..25  EMlsvE
PaDS 26 MMlsvE
o SILICID.. 29 MllsvE
& Va3 a0 svE
METALA 31 [lavi
o Vied 32 ave
@, : METALS 33 W svi
HLRES.34  MMlsvi
18 FWELL 41 = ovf
= N_WELL 42 [llsvt
B ACTIVE 43 8 vi
- . P_PLUS.44 W svE
I I : : : : : : B | NPLUL 45 ot
® poLy 45 [llsve
CONTA.47 8 svf
CONTA..48 svf
METALT 43 [llsvt
via 50 W svE
METAL2 51 Nsvi
OVERG..52 KMlsvf
CONTA...55 v
ELECT.. 56 Wsvi
BURIED..57 MMsvi
PEASE 50 MMsvi
Ccap_w.59  Ellsvi
Thick_A.60 8=t
viaz 61 vt
METALS3 62 IMllsvi
DIFFUS.. 111 Ellavi
mETAL . 143 Illsve
wETAL . 151 Illsve
METAL . 162 [Illsvf
METAL... 163 llsvE
METAL... 164 Bl svE

wPath v Array
wTert v Overflow
“ihape  WPin
“instance v Devis

Mouse:  L: [Full Selection M: [Fstar_stroke() R: [View Area

e Add METALZ: to form Vdd (power wire) and GND (ground wire). Note that
METAL1 should have at least 3 width and 3A spacing (METALL1 to METAL1
spacing).

e Now, connect PMOS-source to Vdd and that of NMOS to GND with METALL.
(Use 'Notch’ — For this select the shape you want to notch or connect and click Edit->
Notch — Use your Left Mouse Button to alter Move the shape as desired and when you
are done press Escape)

e Connect the drains of both transistors by METALL, to get OUTPUT net of the
inverter.
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The figure when you have notched the Vdd, GND and POLY would look as under:

=lBlx|

o Add Edt Seboot ew Comeolvy Iooks el oot Wiwlow o ADK
EE TR X: [27.000 . (18000 Dx: [39.000 Dv: [25.000

Width L Layer. ~| Viastyle: S o |

METALT | BEI
|| tame0as

1C 0: Demo_inverter / Inverter / Layout > Demo_Inverter / Inverter 7 Layout (i)(GE-E)

a5 [av [aF

RO KT

abe

[
A3

viag
METALA 31 [lavi
Vied 32 ave
METALS 53 W ovi
HLRES. 34  Elsvf
F_WELL 41 svf
N_WELL 42 [llsvt
ACTIVE 43 8 vi
P_PLUS.44 W svE
NPLU. 45 W ovi

CONT#..48 svf
METALY 43 [llsvf
via 50 W svE

METAL.. 164 BMlsvi

wPath v Array
wTert v Overflow
~l| vShape  Pin
‘ > | instance v Device
Mouse: L: [Full Selection M: [ §start_stroke() R [View Area

Copyright©2006 15

SantaClara
University




6. Adding Well Ties

e Use Notch to extend the left hand side edges of WELL, ACTIVE (active area), and
METAL1 of the SOURCES of both NMOS & PMOS by 8A.

e AddN_PLUS SELECT inside NWELL and P_PLUS SELECT inside PWELL.
Also add contacts to both N_ PLUS SELECT and P_PLUS_SELECT with 3A
spacing..

e Notice that the PMOS's source is connected to Vdd and NMOS's source is connected
to GND. By connecting the body of the wells to the sources through metall we are
connecting the NWELL to VVdd and the PWELL to GND.

The final figure when you have notched the VVdd, GND and POLY would look shown:

o fdd Edt Gekct \ew Comeolivity Toos el feport Yndow Hep ADK
Eo B g | e st X: [27.000 ¥: [16.000 Dx: [33.000 D¥: [25.000
<1 |31 wicth: Layer: | Wiastyle
IC 0: Demo_inverter £ Inverter / Layout > Dema_inverter § Inverter / Layout (i)(GE-E) WETALT.PORTIMsvE | 1
| tsmenas
o (a7 e
= comm.. 1 ElsvE[4
METAL. 2 [llsuE!
B METAL.3  WMlsvf
(] METAL. 4 EMsvE
ANALOGE  EMl=vE
(=] BB_PAD 7 MMsvE
=~ MARKERS  Ellevi
il METAL. 10 Bfave
() METAL. 11 MEsvE
P_HIGH..21  Ell=vE
I N_HIGH. 22 EBlevE
=l MEMS_.23  Bll=vE
MEMS_.24  Ell=vE
Az CONTA. 25 Ellsvf
PoDs 26 MMlevi
£l sic.. 23 Mlsve
& viaa a0 msvE
METALA 31 WlsvE
[, viaa 5z msur
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7. Making Ports

We will use METALL1 for all ports, so the first thing we must do is route the POLY gate
to a suitable METAL1 trace.

e Select CONTACT TO POLY (47) from the RHS layer palette.

e Create a 2A x 2\ square of CONTACT TO POLY on the left side of the POLY

e Select the POLY trace and use the NOTCH tool to surround the contact by 2A on
each side.

e Add asquare of METALL over the POLY/CONTACT TO POLY pad

The figure should look like the drawing below:
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Labeling Ports:
e Click on the top Metal polygon (Drain of the PMOS) to select it.
¢ From main menu bar, select Connectivity -> Port -> Make Port:
e For the Port Name, enter VDD. Make sure the Port Type is Signal and
Direction is in. Then click OK
e Repeat the steps above to assign GND, IN and OUT ports.

Note: 'GND' and 'IN' are of 'in' Direction while 'OUT" is of 'out' Direction.

22
Fle Add Edit Select Wiew Connectivity Tools Setup  Feport  Window  Help  ADE
= | EUNCCY | = | Select: [T ®: [-17.000 W: [36.000 D¥: [-29.000 DY: [-5.000
] |31 width: b 4 Layer - Wia style Sy |
fIp Bg By L o 2
IC 0: Demo_Inverter ! Inverter / Layout > Demo_Inverter ! Inverter f Layout (i){GE-E) METALY.FORTIM svE| 1
«|[tsmco3s
45 |4 |AF iz
25 comm.. 1 Elsvi|+
METAL.. 2 ElsvE
S METAL... 3  Msvf
0 Make Forl METAL. 4 [Wlsvf
‘PorrName o aMALOGE  Ellsvt
o | . . BB PAD 7 EMsvE
55 Port Type Direction MaRKER S  ElsvE
E + Signal < In METAL... 10  [Blsvf
[ Pawer Out METAL.. 11 @ suf
Feedthru Eidirectional P HIGH.21 El=vE
I | . . H_HIGH. 2z Elevt
|_l__|+ Ok Reset Cancel MEMS_..23  Elsvf
MEMS_ 24  EMsvf
A3 CONTA...25  ElsvE
raDs 26 EMsvE
CJ 1 SiLCiD.. 29 EllevE
& i . - VIA3 a0 e suf
METALS 31 [@lswf
o, Viad 32 svt
m, METALS 33 W svf
HI_RES..34 EMsvf
” F_WELL 41  wm guf
o H_WELL 42 st
i ACTIVE 43 [88svi
P_PLUS. 44 B swf
M_PLU.. 45 B swf
POLY 46 [llsvf
........ = -
v Path v Array
W Text v Owerflow
x| v shape ¥ Fin
bl Ld v Instance |v Dewice
Mouse:  L: |Full Selection h: |§start_stroked) R | Wiew Area
Copyright©2006
(A} :
1 Ay
Santa Clara

University




e Select METAL1.PORT (2) on RHS of the window.

e Select, from main Menu Bar, Add -> Text

e Enter the label VDD and place the text object on the VDD metal line.
e Repeat for the OUT, GROUND, and IN metal lines.

Note: Be sure to label the GND port as GROUND. This name is required for
the LVS check to work correctly.

IC Station, v2006.1_2.2 (p0714063 - Project chsc =1

Layer. [METALLPORT » Valus: [VDD Dv: [9.000
Justification
Height: [T Horizantal: [1ef E Vertical |botiom

£ Inverter f Layout > Demo_inverter { Inverter / Layout (i) (GE-E) METAL1.PORTIsvE |1
| tsme035

Hide Cancel
a5 [a [aF =
COoMM...1  EllsvE[+
METAL. 2 Ellevi
METAL. 3 EMlsvE
METAL. 4  EMlsvE
ANALOGE  EMlsuf
BE PAD 7 MMlsuf
MARKERS  EMlsvf
METAL. 10 #=vE
METAL. 11 @euf
P_HIGH..21  ElsvE
N_HIGH. 22 Illsve
MEMS_.23  IlsuE
MEMS_ 24 Ellsuf
CONTA.25  MMlsvf
PADS 26 MsvE
SiiciD.. 29 MlsvE
vias 30 msuE
METALY 31 EllavE
viad 32 avf,
METALS 33 M8 svE
HLRES. 34 Elsvf
PWELL 41  mm ouf
N_WELL 42 [llsuf
ACTIVE 43 B suf
P_PLUS. 44 W suf
NPLU.. 45 movi
PoLy 46 [HHsvE
: z 7 | . . B | conTe.47  msur
e CONTA..48 suf
METALT 43 Illsvt
via 50 mmsuf
METALZ 51 EMsvE
OWERG..52 MMlsvE
CONTA..55 avE
ELECT.. 56 NNlsvf
BURIED..57 Mlsvt
PEASE 50 WMsuf
CAP_W.59 Wllsuf
Thick_A.60 [B8suf

B OO0 R0 K4

B mu
B¢ un

viaz 61 suf
METAL3 62 WMlsvE
DIFFUS. 111 ElsvE

METAL . 143 IllsvE
METAL . 151 IlsvE
METAL.. 162 Illsuf:
METAL... 163 MMlevE
METAL... 164 Bll=vE

v Path v anay
v Text v Overflow
vsShape  WPin

<

“instance v Device

Mouse:  L: [Next Loeation M: [§start_stroke(y R: [View Area F7-gravity, /D~ dragruler, wy~align, g-drc

Copyright©2006
Y

SantaClara
University




8. Save / Reserve Cell
To save Cell:
e Select, from main Menu Bar, File -> Cell -> Save Cell

Note: After you save your work, the system will automatically set your
work to 'Read-Only" mode. To set your work to 'Editable’ mode ,
Click File> Enable Editing>Current Context

Your final cell should match the one shown below:
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9. DRC/LVS
To Run DRC:
e File 2 Cell - Set Logic Source

Mentor Graphics window Pops up
e Select - Schematic > OK
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From Menu bar:
Click Calibre &> Run DRC

Calibre Interactive_nmDRC window pops up

Select Run DRC on left panel

C Station v2008, C 0: Inverter > inverter (1)
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LVS:

From Menu Bar:

Click on Calibre = Run LVS
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Calibre Interactive _nmLVS eindow pops up

Select Run LVS (on left panel of window)
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If your LVS pass out you get a smiley on the caliber_LVS RVE window as shown below.
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